Back to overview
Degraded

Invoice Notifications

Sep 18 at 06:07pm BST

Resolved
Oct 03 at 12:27am BST

The issue with email notifications affecting billing has been identified and resolved.

Please note that all future invoices shall be created and communicated via a third party platform.

Created
Sep 18 at 06:07pm BST

There appears to be an issue with invoices being sent to clients via email. Invoices are still being generated and are available 24/7 by logging into your client portal. This issue is being investigated.