Back to overview
Downtime

Service Disruption

Sep 13 at 04:50am BST

Resolved
Sep 14 at 09:08am BST

The cause of the issue has been identified and resolved. On-site engineers will be monitoring the situation over the next 24-hours.

Created
Sep 13 at 04:50am BST

S1 - London, UK is currently offline due to a technical issue at the server centre. This outage is affecting multiple servers. On-site technicians are investigating and continue to work towards a resolution.